Greek Font

Last version of DAVAR is now in public betaversion. Here you can report bugs and share ideas how to improve program

Greek Font

Postby ottovonfrankfurt » Tue May 26, 2015 11:54 am

I'm still using XP Pro SP3, so maybe that's a problem, but this appears to be a bug.

I can't get Greek to display diacritics properly.
Very few diacritics appear in the text, but occasionally some do.

Ἰησοῦ shows with a box in place of the diacritic characters.
Programs | Options | Fonts says it's using Arial, but when I try to change it I get this message:

There are no fonts installed
Open the fonts folder... etc.

It's using Calibri, Ezra SIL, Arial, and Arial for the four settings, but I get the same message if I try to change any of them.
Arial Unicode MS and several other good unicode fonts are installed, but it's using Arial which probably doesn't decode the same.
I have nearly 300 fonts installed including Cardo98s, but I can't get to them.

Otto
ottovonfrankfurt
 
Posts: 3
Joined: Tue May 26, 2015 5:51 am

Re: Greek Font

Postby admin » Wed May 27, 2015 7:08 pm

Hello Otto,

D4 is developed on W7/W8.1 and selection of font is working there. Your report is not first, seems I will check calling of SelectFont from common dialog dll, especially on XP.
For now, it is necessary to find if greek is displayed correctly. Please backup davar.cfg and open copy in notepad like editor (notepad++ or PsPad recommended) and you will see on the begin following text - from my current D4 instalation:

Code: Select all
;Davar4 program configuration file.
;Do NOT edit, unless you REALLY know what you do.
;Bad values can crash program easily!
;Syntax: NameOfParameter=value1(,value2,...)
;WARNING - in SOME cases, values are stored in ""
;=====================================================
SaveOnExit=1

RTFCzechFontName="Calibri"
RTFCzechFontSize=24
RTFHebrewFontName="Ezra SIL"
RTFHebrewFontSize=32
RTFGreekFontName="Cardo"
RTFGreekFontSize=27
RTFR2LFontName="Arial"
RTFR2LFontSize=32
Zoom=100


You can enter name of font MANUALLY, GR is line:
RTFGreekFontName="Cardo"
You can try Cardo or some of your font, with unicode Greek. Remember, enter name of font, which is usually different from TTF filename!
Then save (file is UTF-8 encoded without BOM, editor notepad++ should recognize ot) and start D4.

Please post here results of your GR font settings. If this will work, I will get some PC with XP and will check calling font dialog to fix it.

Thanks for report & help
admin
Site Admin
 
Posts: 47
Joined: Fri Mar 20, 2015 8:31 pm

Re: Greek Font

Postby admin » Fri Jun 12, 2015 2:38 pm

This problem was fixed, update will be available in D4 beta2 version.
admin
Site Admin
 
Posts: 47
Joined: Fri Mar 20, 2015 8:31 pm


Return to Davar4 - BUG REPORTS

Who is online

Users browsing this forum: No registered users and 1 guest

cron